Fix for WLW + Blogger error: 400 Bad Request

23Apr08

Several users in the Windows Live Writer forums have reported seeing “Error 400: Bad Request” when publishing to Blogger with images:

(400) Bad Request.

This happens when some values are missing from your Windows registry—specifically, the content types of .jpg, .gif, and/or .png extensions. I don’t know exactly how they are getting removed, but it’s almost certainly a buggy uninstaller from some other application.

In any case, you can fix this problem by running this .reg file. No need to reboot or restart Writer.



44 Responses to “Fix for WLW + Blogger error: 400 Bad Request”

  1. Thank you very much! You are great! I always noticed the 400 Bad Request with Windows Live Writer, but inserting your reg.file everything is running now!
    Thanks!!
    Have a nice day
    Gisella

  2. I inserted the link to your site in my blog
    Ciao
    Gisella

  3. I am so glad i found this entry!! you are wonderful for posting this and i thank you, it’s been days since i have been able to post pictures, and such a quick simple fix!! thanks again. I am also inseting a link back to your page.

    Trina

  4. 4 Alin

    Thanks for the fix! I’ve been affected by this, too, for so many months now…

  5. 5 Pep

    Just wanted to say THANK YOU. This worked for me! All I had to do was:

    right click on the “this reg. file” above
    click on “save link as”
    click “save”
    Go to my desktop (or wherever you saved the file) and double click on it
    It will ask you if you want to add this file to your registry (or something like that), click yes (or OK).

    Go back to Windows Live Writer and try your task again, it should work.

    These directions are for dummies like me who couldn’t figure out what to do at first!

  6. 6 Patti

    Pep, I have tried your instructions, but cannot figure where to put the file. On my PC it does not ask when I double click, it just opens as a text file. Now what?
    Thanks,

  7. 7 Imma

    I’m having the same trouble. I run the file; it says that it’s been instlled, but I still get the same problem. Could you help me, please? Thanks

  8. 8 Shannon

    I tried the ‘reg’ but it’s still giving me the 400 error?

    Thanks for any help..

  9. Shannon, the other common source of 400 error for Blogger is if you’re trying to add a category/label that has a special character in it, such as ‘&’. If that’s not it, you can send me your log file–Help | About | Show log file–my e-mail address is joe.cheng *AT* microsoft.com. Thanks.

    • I never thought a ‘&’ sign would cause so much problems. Thanks so much for you help.

  10. Thank you thank you thank you!!! I love Google. It helps me find you guys who help me fix things.

  11. 12 Amanda

    I have tried the reg, unfortunatly the 400 Bad Request still appear. May I know what could I do next to solve it? Many thanks!

  12. Amanda, you can send me your log file. Help | About | Show log file, and e-mail it to joe.cheng *AT* microsoft.com. Thanks!

  13. 14 Amanda

    Hi Joe, how could I generate the log file? My screen shown “HTTP 400 Error Request” when I run my Internet Explorer.

  14. Amanda, this blog post is only talking about seeing this error in the blog editing program Windows Live Writer.

    If you’re seeing this error while using Internet Explorer, you’ll have to check with whomever runs the site you’re trying to access, as it’s a server-side error.

  15. 16 Amanda

    Noted. Thank you!

  16. when iam trying to login into rcrm.reliancelife.com http400 bad request for internet explorer this is getting.

  17. 18 pedro pabon

    I tried the ‘reg’ but it’s still giving me the 400 error?

    Thanks for any help..

  18. 19 John

    “Shannon, the other common source of 400 error for Blogger is if you’re trying to add a category/label that has a special character in it, such as ‘&’.”

    I had the same error with one of my posts and taking out the ‘&’ symbol corrected it

    • Thank you for the tip about the special character as I had an & symbol between two words. As soon as I removed it the Blog Posted right away.

  19. Hi Im having the same problem as Patti. can you help? and I’ve removed symbols.

  20. The reg file is not working for Windows 7! How to make it into reg file for WINDWOS 7

  21. 23 marie

    Hello Joe,

    It seems you have been able to help many people, so I have hope! My windows live writer displays a message similar to this one saying File Upload Failed The remote server returned an error: (403) Forbidden. What does this mean and how can I fix it? Thanks you so much for your help. I want to smash my computer.

    • Marie, was it previously working fine and then recently started erroring? Or has WLW never been able to upload to Blogger for you? If the former, I think there were some problems on Blogger’s end of things a few days ago, that I would assume are fixed by now.

      • 25 marie

        I posted several posts last year, but haven’t used it in a while. For some reason I can’t get it to work properly now. I’ve tried again several times, but nothing has worked. Any more suggestions for me? Thanks so much for your help.

  22. 26 marie

    I think I figured out the problem. I tried to publish pictures directly through blogger and it said I had exceeded the allowable amount of space for pictures on my web album. I guess this means I have to upgrade or start deleting. Thanks again.

  23. 27 Kim Sophea

    When I post the file to Blogger by using of Window Live Writer, I always got the message: Server Error
    The server reported an error with the following URL:

    http://www.blogger.com/feeds/1965477913233003996/posts/default

    400 Bad Request

    Blog has exceeded rate limit or otherwise requires word verification for new posts

    What can I do for fix of this case

    • Kim: You can log in to Blogger.com and go to the form where you compose a post, there should be a “Word Verification” section that will let you unlock your blog. Once you do that you should be able to post from WLW again.

    • Dear Joe Cheng, I do as your instruction but I still got this message alert when I post via Window Live Writer.

      • 31 vhanla

        I got the similar message, and it was because I was selecting to many labels (categories) for that entry.

  24. 32 Rafael

    Thank you so much! I wasn’t able to find the solution to that problem in forums in my country, but thank Google I found yours. I didn’t need the .reg fix, just the Labels stuff worked! I didn’t know about that Blogger rule. Thank you a lot. I faved your blog here.

  25. Thank you for both the reg and unusual character solutions, I had both and am now post again.

  26. Thank you very very much for this post. Was banging my head against the wall trying to figure it out.

  27. 35 estee

    ive added the reg link ( i have windows 7) and i dont have any unusual characters in my labels and it still doesnt work. any suggestions? thanks for the help

  28. Sorry, I really don’t know–I left the team quite a while ago and have forgotten a lot. You might try http://livewriterblog.wordpress.com. Good luck!

  29. Please help me, every time i try to publish edited post it will shown

    Bad Error 400
    http://www.blogger.com/publish-confirmation.g?blogID=3873526084147803299&postID=2923847906830594025&timestamp=1309406827243&javascriptEnabled=true

    I try reg file but still not working.. clear browsing history not working too😦

  30. 38 noni

    Thank you soooo much! I solved the problem now🙂

  31. thanks so much for your help ..it works to me…

  32. Wow it works ! Thank you sooo much😀

  33. Wonderful work! That is the kind of information that should be shared across the internet. Disgrace on Google for not positioning this put up higher! Come on over and talk over with my site . Thank you =)

  34. Thank you so much for the help. This has been driving me nuts. I ran the reg file and went back to my blog and tried to post and still recieved the error, then I read more of the posts on your Blog that others tried and as soon as I took out a special character from the category/label out of a listing my blog never recieved the error again.

    Answer 19: “Shannon, the other common source of 400 error for Blogger is if you’re trying to add a category/label that has a special character in it, such as ‘&’.”

    I had the same error with one of my posts and taking out the ‘&’ symbol corrected it


  1. 1 PatchworkOfTips Moves To Blogger Platform
  2. 2 404 Bad Request Fehler bei Blogger.com beheben

%d bloggers like this: