Using WLW Blog This with Firefox 2.0

19Oct06

Update Nov 21 2006: New extension released (version 1.0.1) with out-of-the-box Firefox 2.0 compatibility.

As you may or may not know, along with our last beta of Windows Live Writer we also released a Blog This extension for Firefox. The extension works great with Firefox versions between 1.5 and 2.0 Beta 2 (the latest that was available at the time of our release) but not with the 2.0 Release Candidates and final version that have been released since then–Firefox will give you a message that the extension isn’t compatible. It’s possible to get the two to work together, it just involves a little manual editing to get around Firefox’s version checking feature. If you have not installed the Blog This extension yet, follow these steps.

  1. Download the Blog This installer using the link above.
  2. Close Firefox.
  3. Run the Blog This installer.
  4. Without starting Firefox, open the following file in Notepad: C:\Program Files\Windows Live Writer\BlogThis\Mozilla Firefox\install.rdf
  5. Change <em:maxVersion>2.0b2</em:maxVersion> to <em:maxVersion>2.0+</em:maxVersion>.
  6. Start Firefox.

If you have already installed the Blog This extension, follow these steps.

  1. Uninstall the Blog This extension (you can only do this from Add/Remove Programs, not from within Firefox).
  2. Close all Firefox windows, start Firefox again, close Firefox again. (Important!)
  3. Reinstall the Blog This extension.
  4. Follow the above instructions starting from Step 4.
  5. Without starting Firefox, open the following file in Notepad: C:\Program Files\Windows Live Writer\BlogThis\Mozilla Firefox\install.rdf
  6. Change <em:maxVersion>2.0b2</em:maxVersion> to <em:maxVersion>2.0+</em:maxVersion>.
  7. Start Firefox.
  8. If the toolbar does not have a Blog This button like so:

    then right-click the toolbar, select “Customize…”, and drag the Blog This icon from the palette onto the toolbar.

If this doesn’t work for you or isn’t explained clearly enough, please drop me a comment below.



4 Responses to “Using WLW Blog This with Firefox 2.0”

  1. what about IE7? Any hacks for that?

    Thanks for this one as now I got FF2.0 sorted but I also use IE7 (as implied above) and could definitely do with a work around for that too.

  2. 2 danny O'callaghan

    Im using the latest mozilla version. I cannot blog using WLW. Any help


  1. 1 Microsoft Live Writer - awesome! | TechWinter
  2. 2 Get Blog This Plugin Working With Firefox 2.0 by JohnnyCoder

%d bloggers like this: